Boot PXE rien ne se passe

Ici le projet de virtualisation de postes de travail et de VDI (Virtual Desktop Infrastructure)

Re: Boot PXE rien ne se passe

New postby admin » Tue Nov 09, 2010 9:50 am

est ce que le tftp est bien démarré.
Regardes le syslog lorsque le PXE monte pour voir si il braille pas sur les droits des rep.
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Boot PXE rien ne se passe

New postby guidtz » Tue Nov 09, 2010 12:41 pm

De mémoire il ne me semble pas qu'il y ai eu un warning sur les droits j'ai bien vu que tftp essayait de charger le pxelinux.0 mais je te confirme ça ce soir.

Slts
guidtz
 
Posts: 2007
Joined: Sat Jan 17, 2009 3:08 am
Location: Vendée
Artica servers number: 3
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Boot PXE rien ne se passe

New postby guidtz » Tue Nov 09, 2010 9:20 pm

Hello,

en fait c'était un problème de blocage de ports de shorewall.

Maintenant le boot pxe démarre, il scan bien les fichiers de conf pour trouver celui correspondant à l'adresse MAC de la machine :

Code: Select all
Nov  9 22:12:20 symphonix in.tftpd[16650]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:20 symphonix tftpd[16651]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.0
Nov  9 22:12:20 symphonix in.tftpd[16652]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:20 symphonix tftpd[16653]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.0
Nov  9 22:12:20 symphonix in.tftpd[16654]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:20 symphonix tftpd[16655]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/01-00-18-f3-9e-a2-5a
Nov  9 22:12:21 symphonix in.tftpd[16656]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16657]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0A80765
Nov  9 22:12:21 symphonix in.tftpd[16658]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16659]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0A8076
Nov  9 22:12:21 symphonix in.tftpd[16660]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16661]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0A807
Nov  9 22:12:21 symphonix in.tftpd[16662]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16663]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0A80
Nov  9 22:12:21 symphonix in.tftpd[16664]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16665]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0A8
Nov  9 22:12:21 symphonix in.tftpd[16666]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16667]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0A
Nov  9 22:12:21 symphonix in.tftpd[16668]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16669]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C0
Nov  9 22:12:21 symphonix in.tftpd[16670]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16671]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/C
Nov  9 22:12:21 symphonix in.tftpd[16672]: connect from 192.168.7.101 (192.168.7.101)
Nov  9 22:12:21 symphonix tftpd[16673]: tftpd: trying to get file: /var/lib/tftpboot/pxe/pxelinux.cfg/default


Mais j'ai une erreur de boot pxe :
Code: Select all
TFTP server does not support the tsize option
Boot failed


Voici ce que j'ai trouvé :
Code: Select all
Ensure you use the tftpd-hpa package, as PXELINUX requires that the boot server has a TFTP server which supports the “tsize” TFTP option. If you don’t use tftpd-hpa you will most likely see an error such as ‘TFTP server does not support the tsize option’


J'ai essayé thinstation sur un serveur et j'ai utilisé atftpd comme expliqué sur ce post :
http://blog.cheramy.name/2009/12/23/serveur-pxe-et-client-pxe-virtuels/

Dans mon install de test ça boot la version par défaut de thinstation.

Slts
guidtz
 
Posts: 2007
Joined: Sat Jan 17, 2009 3:08 am
Location: Vendée
Artica servers number: 3
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Boot PXE rien ne se passe

New postby guidtz » Mon Nov 15, 2010 12:46 pm

Hello,

as tu trouvé pourquoi ça marchait pas ?

Slts
guidtz
 
Posts: 2007
Joined: Sat Jan 17, 2009 3:08 am
Location: Vendée
Artica servers number: 3
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Boot PXE rien ne se passe

New postby admin » Mon Nov 15, 2010 12:54 pm

est-ce que ca marche mieux après un
Code: Select all
apt-get install tftpd-hpa
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Boot PXE rien ne se passe

New postby guidtz » Tue Nov 16, 2010 9:02 pm

Hello,

j'ai pas réussi à avancer avec tftpd-hpa. Par contre avec atftpd ça marche mieux. Je démarre atftpd en tant que demon /etc/default/atftpd :
Code: Select all
USE_INETD=false
OPTIONS="--daemon --tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=5 /var/lib/tftpboot"


Maintenant le poste client boot une jolie image Artica ThinStation s'affiche la barre de progression avance à 100% et rien ne se passe ensuite. La machine virtuelle est bien démarrée. Par contre dans /var/lib/tftpboot je n'ai pas de fichiers thinstation-MAC

Slts
guidtz
 
Posts: 2007
Joined: Sat Jan 17, 2009 3:08 am
Location: Vendée
Artica servers number: 3
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Boot PXE rien ne se passe

New postby admin » Tue Nov 16, 2010 10:31 pm

je casse tout et recommence avec ton démon atftpd
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Boot PXE rien ne se passe

New postby guidtz » Wed Nov 17, 2010 11:32 am

oki dès que tu as qqchose je test
guidtz
 
Posts: 2007
Joined: Sat Jan 17, 2009 3:08 am
Location: Vendée
Artica servers number: 3
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Boot PXE rien ne se passe

New postby admin » Sun Nov 21, 2010 2:15 pm

en version 1.4.112115 j'ai ajouté le support atftpd
chez moi ca marche.

faire
Code: Select all
apt-get install atftpd

puis
Code: Select all
php5 /usr/share/artica-postfix/exec.tftpd.php --restart
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Boot PXE rien ne se passe

New postby guidtz » Wed Nov 24, 2010 4:35 pm

Ok je regarderais ça fin de semaine prochaine je suis pas mal chargé la.

Slts
guidtz
 
Posts: 2007
Joined: Sat Jan 17, 2009 3:08 am
Location: Vendée
Artica servers number: 3
Linux System: Debian
Technical skills: A Linux System Administrator

PreviousNext

Return to Virtualisation - VDI

Who is online

Users browsing this forum: No registered users and 1 guest

cron