Update not possible anymore and /etc/fstab is not honoured..

About Zarafa appliance or Zarafa managed by Artica

Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Thu Nov 14, 2013 8:03 am

Since last update I can't update anymore...
It is unable to load the index file with curl it says....
If I do it by hand it has no problems with it....

Another side-effect...
This zarafa machine is running as a HyperV machine inside a Windows 8.0 box and it mounts 3 shares from its host
I use /etc/fstab for this...
Since yesterday these mounts aren't mounted after startup...
Code: Select all
//Win8PC.lan/3TB  /mnt/HTPC/3TB  cifs iocharset=utf8,credentials=/home/.smbcredentials,uid=1000 0 0
//Win8PC.lan/4TB  /mnt/HTPC/4TB  cifs iocharset=utf8,credentials=/home/.smbcredentials,uid=1000 0 0
//Win8PC.lan/4TB2 /mnt/HTPC/4TB2 cifs iocharset=utf8,credentials=/home/.smbcredentials,uid=1000 0 0


If I do a "mount -a" these mounts work immediately...
What is causing my system not to respect /etc/fstab???

Code: Select all
root@zarafa64:~# /usr/share/artica-postfix/bin/artica-update --upgrade-nightly --verbose
IsUserExists()::nobody:"65534"
/etc/artica-postfix/MEMORY_INSTALLED -> 249Mn
22457bfe-02b9-68a8-5a88-000025ac89cc;4053960;2;Debian%206.0.8%20Gnu-linux;1.7.111300;zarafa64.jp.home;8;YTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%3D
PROCESS_EXIST(26742): -> checks if exists...
PROCESS_EXIST(26742):/proc/26742/exe does not exists...
PROCESS_EXIST(26742):/proc/26742/cmdline does not exists... -> FALSE
Starting......: Nightly builds checking an official release first
Starting......: Refreshing index file...
Starting......: Source:http://www.artica.fr/auto.update.php
Starting......: dmidecode = 342 bytes
Starting......: Updating repository information..
Starting......: downloading collection
Starting......: Unable to download index file with error 0, {CURLE_COULDNT_CONNECT} (Proxy: no,:)
Starting......: Corrupted Index: /usr/share/artica-postfix/ressources/index.ini..
Starting......: Nightly builds version "" on repository
Starting......: nightly builds Cur:17111300, Next:0
Starting......: nightly builds 17111300/0 "Up to date - Most updated"
root@zarafa64:~# curl http://www.artica.fr/auto.update.php
[NEXT]
artica=1.7.111300
buildtime=1384306122
cakephp=2.3.5
yficake=1.0
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby admin » Thu Nov 14, 2013 9:30 am

It seems when the mount system is executed, your server did not have any networks.
This caused because the Artica init script did not have configured network yet.
I will fix that by adding the mount all in the network script

Before you can do that

create a file
/etc/init.d/artica-ifup-content.sh

put it this

Code: Select all
#!/bin/sh
nohup mount -a >/dev/null 2>&1 &


According the update issue

what is the results of

Code: Select all
php5 /usr/share/artica-postfix/exec.nightly.php --force --verbose
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Thu Nov 14, 2013 2:20 pm

Code: Select all
root@zarafa64:~# php5 /usr/share/artica-postfix/exec.nightly.php --force --verbose
Starting......: class.unix.inc Get local time..
unix/process_exists(9494) /proc/9494/exe no such file Line:4243
Loading /etc/artica-postfix/artica-update.conf
Starting......: Nightly builds checking an official release first
Loading /etc/artica-postfix/artica-update.conf
Starting......: Refreshing index file...
Downloading "http://www.artica.fr/auto.update.php?time=1384438797"
Array
(
    [url] => http://www.artica.fr/auto.update.php?time=1384438797
    [content_type] => text/html
    [http_code] => 200
    [header_size] => 243
    [request_size] => 83
    [filetime] => -1
    [ssl_verify_result] => 0
    [redirect_count] => 0
    [total_time] => 0.290136
    [namelookup_time] => 0.047327
    [connect_time] => 0.102399
    [pretransfer_time] => 0.102407
    [size_upload] => 0
    [size_download] => 12553
    [speed_download] => 43265
    [speed_upload] => 0
    [download_content_length] => -1
    [upload_content_length] => 0
    [starttransfer_time] => 0.177448
    [redirect_time] => 0
    [certinfo] => Array
        (
        )

    [redirect_url] =>
    [request_header] => GET /auto.update.php?time=1384438797 HTTP/1.1
Host: www.artica.fr
Accept: */*


)
Loading /etc/artica-postfix/artica-update.conf
Starting......: Source:http://www.artica.fr/auto.update.php
EXEC_NICE: cgroupsEnabled=0, ArticaInCgroups=0 ArticaCgroup=0
EXEC_NICE: cgroupsEnabled=0, ArticaInCgroups=0 ArticaCgroup=0
Loading /etc/artica-postfix/artica-update.conf
Loading /etc/artica-postfix/artica-update.conf
unix::MAIN_URI[105] www.artica.fr = 93.88.245.88
PHP: 5.3.27-1~dotdeb.0
Not using proxy...
GET /routers.inject.php?time=1384438797 HTTP/1.1
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Host: www.artica.fr
Accept: */*

***** 200 *****
Failed
Starting......: dmidecode = 342 bytes
Starting......: Updating repository information..
Fatal..:
Warning: md5_file(/usr/share/artica-postfix/ressources/index.ini): failed to open stream: No such file or directory in /usr/share/artica-postfix/exec.nightly.php on line 79

Starting......: downloading collection
CURLOPT_INTERFACE: 127.0.0.1 656
Downloading "http://www.artica.fr/auto.update.php?time=1384438798&datas=22457bfe-02b9-68a8-5a88-000025ac89cc%3B4053960%3B2%3BDebian+6.0.8+Gnu-linux%3B17111300%3Bzarafa64.jp.home%3B8%3BYTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%253D"
Array
(
    [url] => http://www.artica.fr/auto.update.php?time=1384438798&datas=22457bfe-02b9-68a8-5a88-000025ac89cc%3B4053960%3B2%3BDebian+6.0.8+Gnu-linux%3B17111300%3Bzarafa64.jp.home%3B8%3BYTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%253D
    [content_type] =>
    [http_code] => 0
    [header_size] => 0
    [request_size] => 0
    [filetime] => -1
    [ssl_verify_result] => 0
    [redirect_count] => 0
    [total_time] => 0
    [namelookup_time] => 1.4E-5
    [connect_time] => 0
    [pretransfer_time] => 0
    [size_upload] => 0
    [size_download] => 0
    [speed_download] => 0
    [speed_upload] => 0
    [download_content_length] => -1
    [upload_content_length] => -1
    [starttransfer_time] => 0
    [redirect_time] => 0
    [certinfo] => Array
        (
        )

    [redirect_url] =>
)
ccurl/ParseError(7)
[24600] [DAEMON]::::ccurl/ParseError:: error 7 Failed to connect() to host or proxy (Proxy: no, :) called by exec.nightly.php GetFile() line 83 in class.ccurl.inc line 602
[24600] [DAEMON]::::ccurl/GetFile:: datas: http://www.artica.fr/auto.update.php?time=1384438798&datas=22457bfe-02b9-68a8-5a88-000025ac89cc%3B4053960%3B2%3BDebian+6.0.8+Gnu-linux%3B17111300%3Bzarafa64.jp.home%3B8%3BYTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%253D (0 bytes) error:7 in class.ccurl.inc
Starting......: Unable to download index file with error 0, {CURLE_COULDNT_CONNECT} (Proxy: no,:)
Loading /usr/share/artica-postfix/ressources/index.ini
Starting......: Corrupted Index: /usr/share/artica-postfix/ressources/index.ini..
Fatal..:
Notice: Undefined index: lastest-nightly in /usr/share/artica-postfix/exec.nightly.php on line 389

Starting......: Nightly builds version "" on repository
Starting......: nightly builds Cur:17111300, Next:0
Starting......: nightly builds 17111300/0 "Up to date - Most updated"
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Thu Nov 14, 2013 2:29 pm

The mount issue was solved...
Script did need a chmod +x
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Fri Nov 15, 2013 8:30 am

I posted the output of the forced update....
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby admin » Wed Nov 20, 2013 1:17 am

could you perform this in 1H

Code: Select all
cd /root && wget http://www.artica.fr/nightbuilds/artica-1.7.112001.tgz && tar -xf artica-1.7.112001.tgz -C /usr/share/
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Wed Nov 20, 2013 11:46 am

The update itself succeeded, but there is still no solution to the update function....

Code: Select all
Starting......: Nightly builds version "" on repository
Starting......: nightly builds Cur:17112001, Next:0
Starting......: nightly builds 17112001/0 "Up to date - Most updated"


I have a feeling it has something to do with the network settings...

My network is AFAIK properly set, but the WebIF states it is not.
See screenshot

My Zarafa and WebAPP still isn't updated.
Is this related?

Code: Select all
root@zarafa64:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
127.0.0.1       0.0.0.0         255.255.255.255 UH    0      0        0 lo
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.2.254   0.0.0.0         UG    0      0        0 eth0
root@zarafa64:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:15:5d:02:18:01
          inet addr:192.168.2.28  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::215:5dff:fe02:1801/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19680 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6716961 (6.4 MiB)  TX bytes:7778613 (7.4 MiB)
          Interrupt:9 Base address:0xec00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.255.255.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:69473 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69473 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:19521581 (18.6 MiB)  TX bytes:19521581 (18.6 MiB)

root@zarafa64:~# ping -c1 www.google.nl
PING www.google.nl (173.194.66.94) 56(84) bytes of data.
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=1 ttl=50 time=25.3 ms

--- www.google.nl ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 25.362/25.362/25.362/0.000 ms
Attachments
Zarafa.JPG
Zarafa.JPG (22.86 KiB) Viewed 7845 times
artica-network.JPG
artica-network.JPG (121.72 KiB) Viewed 7845 times
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby admin » Wed Nov 20, 2013 11:51 am

Could you resend to me the debug mode...
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Wed Nov 20, 2013 12:34 pm

Here you are...
BTW I tried (remotely even) change the network settings and looked if there was something strange going on...
No change...

Updates were fine until I updated it using that same command...

Code: Select all
root@zarafa64:~# php5 /usr/share/artica-postfix/exec.nightly.php --force --verbose
Starting......: class.unix.inc Get local time..
unix/process_exists(931) /proc/931/exe no such file Line:4243
Loading /etc/artica-postfix/artica-update.conf
Starting......: Nightly builds checking an official release first
Loading /etc/artica-postfix/artica-update.conf
Starting......: Refreshing index file...
Downloading "http://www.artica.fr/auto.update.php?time=1384950758"
Array
(
    [url] => http://www.artica.fr/auto.update.php?time=1384950758
    [content_type] => text/html
    [http_code] => 200
    [header_size] => 243
    [request_size] => 83
    [filetime] => -1
    [ssl_verify_result] => 0
    [redirect_count] => 0
    [total_time] => 0.178277
    [namelookup_time] => 0.029677
    [connect_time] => 0.071124
    [pretransfer_time] => 0.071128
    [size_upload] => 0
    [size_download] => 12553
    [speed_download] => 70412
    [speed_upload] => 0
    [download_content_length] => -1
    [upload_content_length] => 0
    [starttransfer_time] => 0.131834
    [redirect_time] => 0
    [certinfo] => Array
        (
        )

    [redirect_url] =>
    [request_header] => GET /auto.update.php?time=1384950758 HTTP/1.1
Host: www.artica.fr
Accept: */*


)
Loading /etc/artica-postfix/artica-update.conf
Starting......: Source:http://www.artica.fr/auto.update.php
EXEC_NICE: cgroupsEnabled=0, ArticaInCgroups=0 ArticaCgroup=0
EXEC_NICE: cgroupsEnabled=0, ArticaInCgroups=0 ArticaCgroup=0
Loading /etc/artica-postfix/artica-update.conf
Loading /etc/artica-postfix/artica-update.conf
unix::MAIN_URI[105] www.artica.fr = 93.88.245.88
PHP: 5.3.27-1~dotdeb.0
Not using proxy...
GET /routers.inject.php?time=1384950759 HTTP/1.1
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Host: www.artica.fr
Accept: */*

***** 200 *****
ParseCodeError:: Parsing CURLINFO_HTTP_CODE:200
ParseCodeError:: 200 < 400 return true
HTTP/1.1 200 OK
Date: Wed, 20 Nov 2013 12:32:38 GMT
Server: Apache
Content-Length: 11
Content-Type: text/html


ccurl/get(): Error:0
Starting......: dmidecode = 342 bytes
Starting......: Updating repository information..
Fatal..:
Warning: md5_file(/usr/share/artica-postfix/ressources/index.ini): failed to open stream: No such file or directory in /usr/share/artica-postfix/exec.nightly.php on line 79

Starting......: downloading collection
CURLOPT_INTERFACE: 127.0.0.1 657
Downloading "http://www.artica.fr/auto.update.php?time=1384950759&datas=22457bfe-02b9-68a8-5a88-000025ac89cc%3B4053960%3B2%3BDebian+6.0.8+Gnu-linux%3B17112001%3Bzarafa64.jp.home%3B8%3BYTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%253D"
Array
(
    [url] => http://www.artica.fr/auto.update.php?time=1384950759&datas=22457bfe-02b9-68a8-5a88-000025ac89cc%3B4053960%3B2%3BDebian+6.0.8+Gnu-linux%3B17112001%3Bzarafa64.jp.home%3B8%3BYTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%253D
    [content_type] =>
    [http_code] => 0
    [header_size] => 0
    [request_size] => 0
    [filetime] => -1
    [ssl_verify_result] => 0
    [redirect_count] => 0
    [total_time] => 0
    [namelookup_time] => 1.4E-5
    [connect_time] => 0
    [pretransfer_time] => 0
    [size_upload] => 0
    [size_download] => 0
    [speed_download] => 0
    [speed_upload] => 0
    [download_content_length] => -1
    [upload_content_length] => -1
    [starttransfer_time] => 0
    [redirect_time] => 0
    [certinfo] => Array
        (
        )

    [redirect_url] =>
)
ccurl/ParseError(7)
[1533] [DAEMON]::::ccurl/ParseError:: error 7 Failed to connect() to host or proxy (Proxy: no, :) called by exec.nightly.php GetFile() line 83 in class.ccurl.inc line 603
[1533] [DAEMON]::::ccurl/GetFile:: datas: http://www.artica.fr/auto.update.php?time=1384950759&datas=22457bfe-02b9-68a8-5a88-000025ac89cc%3B4053960%3B2%3BDebian+6.0.8+Gnu-linux%3B17112001%3Bzarafa64.jp.home%3B8%3BYTo2OntzOjEyOiJNQU5VRkFDVFVSRVIiO3M6OToidmlydHVhbHBjIjtzOjc6IlBST0RVQ1QiO3M6OToidmlydHVhbHBjIjtzOjc6IkNIQVNTSVMiO3M6OToidmlydHVhbHBjIjtzOjEwOiJQUk9DRVNTT1JTIjtpOjI7czozOiJNSFoiO2Q6Mi44OTk5OTk5OTk5OTk5OTk5MTExODIxNTgwMjk5ODc0NzY3NjYxMDk0NjY1NTI3MzQzNzU7czo5OiJQUk9DX1RZUEUiO3M6NDA6IkludGVsKFIpIENvcmUoVE0pIGk1LTQ1NzBTIENQVSBAIDIuOTBHSHoiO30%253D (0 bytes) error:7 in class.ccurl.inc
Starting......: Unable to download index file with error 0, {CURLE_COULDNT_CONNECT} (Proxy: no,:)
Loading /usr/share/artica-postfix/ressources/index.ini
Starting......: Corrupted Index: /usr/share/artica-postfix/ressources/index.ini..
Fatal..:
Notice: Undefined index: lastest-nightly in /usr/share/artica-postfix/exec.nightly.php on line 389

Starting......: Nightly builds version "" on repository
Starting......: nightly builds Cur:17112001, Next:0
Starting......: nightly builds 17112001/0 "Up to date - Most updated"
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Update not possible anymore and /etc/fstab is not honoured..

New postby frater » Wed Nov 20, 2013 12:58 pm

I got rid of that message in Network Settings by making the 192.168.2.254 the DEFAULT gateway (clicking checkbox)
I did a reboot to make sure, but the problem with curl in the update script persists....
frater
 
Posts: 127
Joined: Sun Jul 08, 2012 9:35 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Next

Return to Zarafa mail server

Who is online

Users browsing this forum: No registered users and 2 guests

cron