INFO MAUVAISE CONFIG OPENDNS

Société Locate

INFO MAUVAISE CONFIG OPENDNS

New postby ypatel » Wed Nov 30, 2011 10:54 am

Suite a une mauvaise config dans OPENDNS, j'ai mis en Ip 192.168.0.241 et apres ca, j'ai perdu la connexion sur le serveur (j'ai du aller directement taper des commandes sur le serveur).

j'ai fait un KILLALL OPENVPN = OK je pouvais a nouveau pinger le proxy 0.17.
dans les inteface reseau j'ai vu une nouvelle carte ETN00 (ou TN00 avec en ip 192.168.0.1...)

Par contre, je voulais aller retablir la config dans l'interface, impossible, ca tourne en boucle je n'ai pas acces a la config.

J'ai voulu désinstaller et reinstaller le module open vpn (apt-get remove openvpn et apt-get install openvpn) le probleme est qu'en re installant, la mauvaise config re apparait et je perd a nouveau la main a distance sur le serveur et sur l'interface web.

j'ai donc refait un killall OPENVPN et un apt-get remove.

Question :
Il faut re installer le module OPENVPN mais qu'il soit desactive car sinon on perd la main. et il faut intervenir sur la machine.
Donc ,je suppose qu'il faut effacer des fichiers de configurations qui serait resté dans les module Artica, comment les retrouver et le supprimer

Donc je vais attendre que tu puisse jeter un oeil dessus afin de bien le re paramétrer

ps : lorsque je faisais un killall openvpn, le service se relancait quelques minutes apres, peut etre un watchdog d'artica ?
Attachments
OpenVPN.JPG
OpenVPN.JPG (74.41 KiB) Viewed 9117 times
ypatel
 
Posts: 79
Joined: Fri Aug 22, 2008 1:05 am

Re: INFO MAUVAISE CONFIG OPENDNS

New postby admin » Thu Dec 01, 2011 12:20 am

Votre config est mauvaise !

Vous ne pouvez pas affecter les adresses 192.168.x.x (vous avez mis 192.168.0.0) à un réseau VPN qui est sur la même tranche que votre réseau interne.
Vous devez obligatoirement affecter un autre réseau 8.0.0.0 ou 172.16.0.0 mais pas 192.168.x
User avatar
admin
Site Admin
 
Posts: 11954
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: INFO MAUVAISE CONFIG OPENDNS

New postby ypatel » Mon Dec 05, 2011 12:08 pm

Pour pouvoir changer l'IP, chose que je n'arrivait pas, j'ai du :
Désinstaller Open VPN
Depuis sur l'interface et la j'avais accès au fichier de config, j'ai pu changer le port
Re installer open VPN
Reboot


C'est maintenant OK, par contre, j'ai cette erreur
Mon Dec 05 15:57:16 2011 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)

J'ai juste fait l'initialisation de la cle et decompresser le fichier ZIP dans le dossier\config d'openVPN

voici le schéma, il y a encore u ne erreur (local network) tu vois d'où ca peut venir ?

ps : pour info, j'ai fai tun telnet sur le port 1194, pas de reponse (port fermé?)
telnet: connect to address 192.168.0.17: Connection refused

Tu vois d'où peut venir l'erreur ?
Attachments
Open VPN 3.JPG
Open VPN 3.JPG (47.3 KiB) Viewed 9102 times
OpenVPN-2.JPG
OpenVPN-2.JPG (38.03 KiB) Viewed 9102 times
ypatel
 
Posts: 79
Joined: Fri Aug 22, 2008 1:05 am

Re: INFO MAUVAISE CONFIG OPENDNS

New postby admin » Mon Dec 05, 2011 2:14 pm

Attention c'est de l'UDP pas du TCP...
User avatar
admin
Site Admin
 
Posts: 11954
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: INFO MAUVAISE CONFIG OPENDNS

New postby ypatel » Tue Dec 06, 2011 4:13 am

admin wrote:Attention c'est de l'UDP pas du TCP...



C'est bien ce que j'ai mis : UDP
ypatel
 
Posts: 79
Joined: Fri Aug 22, 2008 1:05 am

Re: INFO MAUVAISE CONFIG OPENDNS

New postby ypatel » Thu Dec 08, 2011 5:58 am

J'ai reussi a le lancer, par contre, en dehors de mon serveur qui gere l'open VPN (192.168.0.17) je ne peux pinger aucun autre serveur ou poste

Le probleme doit se situer au niveau routes/passerelles


voici un exemple lorsque je demarre Open VPN , j'ai mis en rouges les routes que j'ai ajouté, mais je pense que c'est erroné

/etc/init.d/artica-postfix start openvpn
Starting......: OpenVPN tunnel type...: "tun"...
Starting......: OpenVPN ressources....: /usr/share/artica-postfix/bin/install/openvpn...
Starting......: OpenVPN version.......: 2.1.0...
Starting......: OpenVPN IP Forwarding is enabled
Starting......: OpenVPN server verify key "vpn-server.key" in /etc/artica-postfix/openvpn/keys directory
Starting......: OpenVPN building settings for GUARDIANS...
Starting......: OpenVPN linked to eth0 (192.168.0.17)...
Starting......: OpenVPN route --push "route 24 255.255.0.0"
Starting......: OpenVPN route --push "route 0.0.0.0 255.0.0.0"
Starting......: OpenVPN route --push "route 192.168.0.0 255.255.255.0"
Starting......: OpenVPN route --push "route 192.168.200.0 255.255.255.0
"

Starting......: OpenVPN IP adding 4 routes
Starting......: OpenVPN IP pool from 192.168.150.2 to 192.168.150.254 mask:255.255.255.0
Starting......: OpenVPN duplicate-cn is enabled
Starting......: OpenVPN script-security is enabled
Starting......: OpenVPN get remote sites routes...
Starting......: OpenVPN building /etc/openvpn/cmdline.conf done
Starting......: OpenVPN building settings done.
Starting......: OpenVPN Success with PID number 27547
Starting......: OpenVPN cleaning iptables 0 rules
Starting......: OpenVPN prerouting success from tun0 -> eth0...
ypatel
 
Posts: 79
Joined: Fri Aug 22, 2008 1:05 am

Re: INFO MAUVAISE CONFIG OPEN VPN

New postby ypatel » Thu Dec 08, 2011 6:11 am

Bon, j'ai reussi, c'etait les routes
Starting......: OpenVPN route --push "route 24 255.255.0.0"
Starting......: OpenVPN route --push "route 0.0.0.0 255.0.0.0"

que j'ai viré et la c'est bon.

J'arrive a lancer des appli hegerbé sur des serveurs locaux, par contre, pas d'acces aux serveurs mail ou interface de serveur sur artica bien que je les ping bien (proxy, mailserver, samba) est ce normal ou une regle de securite ?
ypatel
 
Posts: 79
Joined: Fri Aug 22, 2008 1:05 am

Re: INFO MAUVAISE CONFIG OPENDNS

New postby admin » Thu Dec 08, 2011 7:22 pm

C'est à dire, que voulez-vous faire ?
User avatar
admin
Site Admin
 
Posts: 11954
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: INFO MAUVAISE CONFIG OPENDNS

New postby ypatel » Fri Dec 09, 2011 6:41 am

Je voulais intervenir sur un serveur linux interne par un putty je n'ai pas acces.
ypatel
 
Posts: 79
Joined: Fri Aug 22, 2008 1:05 am


Return to LOCATE

Who is online

Users browsing this forum: No registered users and 1 guest

cron