Installation VirtualBox artica-full.debian6 [CLOSED]

Ici , tout ce qui concerne les problèmes d'installation de ARTICA

Installation VirtualBox artica-full.debian6 [CLOSED]

New postby method » Wed Sep 07, 2011 4:51 pm

Bonjour,

Je rencontre un problème après l'installation de la dernière ISO.

L'installation à l'air de bien de finaliser en revanche :

Les mots de passe root : artica et qrticq ne fonctionnent pas
L'interface ethernet est introuvable

Pour les logs :

starting apache 2 failed
samba smbd nmbd failed
postfix failed
aucune interface réseau trouvée

Ma configuration :
Ubuntu 11.04
VirtualBox 4.1
Ethernet bridgée
2048 RAm
2 processeurs
IO-APIC activé
Last edited by method on Wed Sep 28, 2011 5:18 pm, edited 2 times in total.
method
 
Posts: 6
Joined: Wed Sep 07, 2011 4:35 pm
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Installation VirtualBox artica-full-1.5.082813.debian6

New postby admin » Wed Sep 07, 2011 8:58 pm

Changez le mode de l'interface dans votre virtualbox (vous avez deux modes)
essayez "fai" comme mot de passe

attention azerty => fqi
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Installation VirtualBox artica-full-1.5.082813.debian6

New postby method » Tue Sep 13, 2011 8:06 pm

Bonsoir,

Merci pour le passwd root fqi > fai

J'ai pu basculer en azerty avec un loadkeys fr

En revanche, j'ai modifié et testé tous les modes de l'interface réseau de VirtualBox :
NAT
Bridge
Réseau Interne
Réseau hote privé
Pilote générique

Testé avec toutes les options différentes. Rien n'y fait. Le chargement des pilotes n'est pas pris en compte. Est ce la version du kernel du FAI qui n'est pas capable de charger les pilotes ?

Le fichiers /etc/network/interfaces est vide auriez vous une idée ?

ifconfig up eth0
ifup eth0 ne retournent rien.

un lspci affiche bien les interfaces de la virtualbox .....

Merci
method
 
Posts: 6
Joined: Wed Sep 07, 2011 4:35 pm
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Installation VirtualBox artica-full-1.5.082813.debian6

New postby admin » Tue Sep 13, 2011 10:02 pm

est-ce qu'un
Code: Select all
ifconfig eth0 192.168.1.xx netmask 255.255.255.0 up

permet d'afficher un ifconfig correct ?
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Installation VirtualBox artica-full-1.5.082813.debian6

New postby method » Wed Sep 14, 2011 1:05 pm

Bonjour,


J'ai pu solutionner l'erreur en changeant le nom de l'interface . eth0 n'est pas pris en compte c'est le flag eth1 qui l'est.

J'ai donc alimenté le /etc/network/interfaces :
auto eth1
iface eth1 inet static
address 192.168.0.102
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.XXX.XXX


Les deamons apache2, mysql ne démarrent pas :

Après avoir installé 2 fois l'ISO, au boot apache retourne la même erreur au démarrage, l'interface eth1 est bien démarrée :
Starting web server : apache2apache2: apr_sockaddr_info_get() failed for artica box

EDIT :
J'ai alimenté le fichier /etc/hosts afin qu'apache puisse démarrer correctement :
127.0.0.1 localhost articabox

Après l'avoir alimenté j'ai des erreurs au niveau de lighttpd :
can't bind to port 80 : adress already in use

Ce que je ne saisi pas, c'est pourquoi 2 serveur web travaillent ensemble. A priori ils rentrent en conflit.

merci pour votre aide
method
 
Posts: 6
Joined: Wed Sep 07, 2011 4:35 pm
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Installation VirtualBox artica-full-1.5.082813.debian6

New postby admin » Wed Sep 14, 2011 10:26 pm

Il manque la procédure complète d'installation.
Cela est du au fait que les scripts ne sont pas démarrés tant que le réseau n'est pas fonctionnel.
que dit la commande

Code: Select all
/usr/share/artica-postfix/bin/artica-iso
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Installation VirtualBox artica-full-1.5.082813.debian6

New postby method » Wed Sep 28, 2011 11:42 am

Bonjour,

Effectivement, cela fonctionne maintenant. En revanche je dois modifier l'interface c'est eth1 qui est pris en compte.

Merci. Par contre je n'ai pas vu dans la documentation la nécessité d’exécuter cette commande. (Est ce que j'ai raté quelque chose ?)

Code: Select all
    /usr/share/artica-postfix/bin/artica-iso


Merci encore pour l'aide

J'ai par ailleurs testé Artica sur Debian Squeeze avec le setup d'installation. L'installation s'est faite correctement aussi.
method
 
Posts: 6
Joined: Wed Sep 07, 2011 4:35 pm
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron