Problème graph + erreurs SQL

Une coquille dans l'interface Artica, des bugs....

Problème graph + erreurs SQL

New postby erase » Tue May 31, 2016 9:26 am

Bonjour,

Je rencontre quelques problèmes avec la mise en place d'artica.

J'ai déjà testé artica au sein d'une VM il y à quelque temps et tout semblait fonctionner correctement. Nous avons donc commandé une machine spécialement dédiée à artica et installé dessus artica mais je rencontre de nombreux problèmes.
Pour info, la version d'artica testée il y à un moment était "Artica v.2.24.101202 | Proxy v3.5.10 " et la version testée actuellement est la dernière en date : "Artica v.2.39.053019 | Proxy v3.5.17 " le tout installé avec l'image iso fournie sur votre site.

Premièrement : Dans le moniteur de service de la rubrique SQL j'ai de très nombreuses erreurs : FATAL MySQL error Error Number (1146) (Table 'squidlogs.dns_servers' doesn't exist)
Ensuite je ne sais pas si cela est lié, mais les graphiques des rapports des stats ne fonctionne pas ou très mal. Il m'affiche des camemberts invisible ou bien incomplet. Après plusieurs désinstallation / réinstallation d'artica.

J'ai mis en pièce jointe une image montrant le souci.

Autre chose étrange mais pouvant ne pas être un bug : dans l'onglet client actif du tableau de bord la résolution des noms semble se faire de manière aléatoire malgré que les postes soient dans le domaine et que la connexion à l'AD soit activée (voir pièce jointe client actif pour une image).

Petit edit : Je pense que le soucis viens d'une version entre la v.2.24.101202 et la 2.39.053019 car ayant encore la VM qui tourne sur la 2.24 les graph marchent correctement (testé à l'instant) alors que sur la dernière version ça ne marche pas.

En vous remerciant par avance.

Cordialement,
Attachments
clientactif.PNG
clientactif.PNG (29.33 KiB) Viewed 4677 times
bugartica.PNG
Problème de graphique
bugartica.PNG (102.6 KiB) Viewed 4677 times
erase
 
Posts: 6
Joined: Fri Oct 16, 2015 1:26 pm
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Problème graph + erreurs SQL

New postby admin » Tue May 31, 2016 11:48 am

Nous sommes au courant de ce problème.
Il est en parti règlé sur la 2.39 ( version beta ) / 2.40 ( version release ).

"client actif du tableau de bord": Corrigé en v2.39 qui sera libérée après-demain.
FATAL MySQL error Error Number (1146) (Table 'squidlogs.dns_servers' doesn't exist) : Photo d'écran ?
les graphiques des rapports des stats ne fonctionne pas ou très mal: La différence entre la 2.24 et 2.38 est que nous avons scindé les statistiques en statistiques "chaudes" : 24H et statistiques à long terme > 24H
Ce problème est normalement corrigé avec la version actuelle 2.39.

Toujours est-il est que vous pouvez repasser en 2.24
http://articatech.net/v10-officials/art ... 101202.tgz
avec la fontion de mise à jour manuelle et passer en 2.40 stable le jour venu.

ps: Pour les clients artica, veuillez passer par http://bugs.articatech.com/ ou par http://support.artica.fr
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Problème graph + erreurs SQL

New postby erase » Tue May 31, 2016 12:15 pm

Merci de votre réponse encore une fois rapide !
Ci-joint les captures d'écran des erreurs SQL.

Cependant je ne comprend pas tout à fait le problème des graphiques de rapports de stats et le fait d'avoir des statistiques "chaude et long terme". Le fait d'avoir des graph comme sur ma capture est il un comportement "normal" et la fonction de graph ne fonctionne pas de suite et il faut attendre avant de générer un autre rapport qui lui affichera correctement ces graphiques ?

Concernant la mise à jour manuelle en 2.24, je peux laisser la dernière version de SQUID ou bien faut il de préférence la downgrade elle aussi ? Et le fait de repasser en 2.24 n'a pas d'impact sur le bon fonctionnement du proxy ? (bug ou autre réglé entre temps ?)

Pour finir nous sommes en phase de mise en place / test final avant l'achat, donc n'avons pas encore accès aux deux urls.

Merci encore.
Attachments
mysql2.PNG
mysql2.PNG (21.95 KiB) Viewed 4669 times
mysql1.PNG
mysql1.PNG (108.12 KiB) Viewed 4669 times
erase
 
Posts: 6
Joined: Fri Oct 16, 2015 1:26 pm
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: Problème graph + erreurs SQL

New postby admin » Tue May 31, 2016 11:05 pm

Cependant je ne comprend pas tout à fait le problème des graphiques de rapports de stats et le fait d'avoir des statistiques "chaude et long terme". Le fait d'avoir des graph comme sur ma capture est il un comportement "normal" et la fonction de graph ne fonctionne pas de suite et il faut attendre avant de générer un autre rapport qui lui affichera correctement ces graphiques ?

Oui c'est un comportement normal, pour "simplifier" on peut dire que c'est un bug dans la requête SQL.

Concernant la mise à jour manuelle en 2.24, je peux laisser la dernière version de SQUID ou bien faut il de préférence la downgrade elle aussi ? Et le fait de repasser en 2.24 n'a pas d'impact sur le bon fonctionnement du proxy ? (bug ou autre réglé entre temps ?)

Non, il n'y a pas d'impact sur le proxy.

Merci pour la photo d'écran, nous allons corriger cela pour la 2.39x
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France


Return to Interface d'administration

Who is online

Users browsing this forum: No registered users and 10 guests

cron