cyrus-imap validating against Active Directory [CLOSED]

All questions about cyrus-imap used by artica

Re: Artica with cyrus-imap validating against Active Directory

New postby garaujo » Sat Oct 16, 2010 1:41 am

Hello, i try to test it, but when clicked, nothing happend, no window, no popup, nothing ...

Another issue is that is duplicating the menu ... see screen

dup.jpg
dup.jpg (45.67 KiB) Viewed 4877 times


Thanks.
--

Ing. Gonzalo Araujo C
MCSE, MCSA, MCSD, ITIL, CISSP, C|EH, LPI
SLM Sistemas - Ingenio Virtual
http://www.slmsistemas.com
Colombia - Guatemala - Chile - Venezuela
User avatar
garaujo
 
Posts: 31
Joined: Sun Sep 12, 2010 4:58 pm
Location: Caracas / Venezuela
Artica servers number: 10
Linux System: CentOS
Technical skills: A Linux developper

Re: Artica with cyrus-imap validating against Active Directory

New postby admin » Sat Oct 16, 2010 12:10 pm

the icon is activated only if artica found kinit program

/usr/share/artica-postfix/bin/process1 is in charge to fill the

Code: Select all
/usr/share/artica-postfix/ressources/settings.inc


process1 is executed periodically, you just have to wait few minutes.

or execute

Code: Select all
/usr/share/artica-postfix/bin/process1 --force --verbose


to enable the icon, the entry KINIT_INSTALLED must be true

you can check it by do this

Code: Select all
cat /usr/share/artica-postfix/ressources/settings.inc|grep KINIT_INSTALLED


i will fix this double display in next nighlty build.
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Artica with cyrus-imap validating against Active Directory

New postby garaujo » Sat Oct 16, 2010 1:49 pm

Hello david, kinit is installed, but still dosen't work ... process1 maybe is searching for something else? where is artica searching for kinit? in centos is in the /usr/kerberos/bin/kinit as show:

Code: Select all
[root@LinuxArtica ~]# kinit
kinit(v5): Cannot resolve network address for KDC in realm EXAMPLE.COM while getting initial credentials
[root@LinuxArtica ~]# find / -name 'kinit'
/usr/kerberos/bin/kinit
[root@LinuxArtica ~]# cat /usr/share/artica-postfix/ressources/settings.inc|grep KINIT_INSTALLED
$_GLOBAL["KINIT_INSTALLED"]=False;
[root@LinuxArtica ~]# /usr/share/artica-postfix/bin/process1 --force
Starting......: postfix creating /etc/postfix/sasl/smtpd.conf
Starting......: saslpasswd: /usr/sbin/saslpasswd2
Starting......: Artica version 1.4.101516
Starting......: Kernel version 2.6
Starting......: Distribution "CentOS release 5" i386
Starting......: unable to stat /etc/init.d/keymap.sh
Starting......: OpenLDAP /etc/ssl/certs/openldap/ca.crt OK
Starting......: OpenLDAP /etc/ssl/certs/openldap/ldap.crt OK
Starting......: OpenLDAP /etc/ssl/certs/openldap/ldap.key OK
Starting......: OpenLDAP is already running using PID 32302...
Starting......: artica-postfix daemon watchdog (fcron) is already running using PID 32320...
Starting......: Daemon (fcron) is already running using PID 32464...
Starting......: sysloger already running with pid 2668
Starting......: sysloger realtime process number:1
Starting......: Mysql is already running using PID 2772...
Starting......: Mysql-cluster is not installed, abort
Starting......: Mysql-cluster replica is not installed, abort
Starting lighttpd............: phpldapadmin is not installed
Starting......: framework daemon is already running using PID 31728...
Starting Apache..............: Apache bin: /usr/sbin/httpd
Starting Apache..............: LibPhp5...: /usr/lib/httpd/modules/libphp5.so
Starting Apache..............: ModSSL....: /usr/lib/httpd/modules/mod_ssl.so
Starting Apache..............: lighttpd..: /usr/sbin/lighttpd
Starting......: lighttpd daemon is already running using PID 31835...
Starting......: BOA daemon is already running using PID 31666...
Starting......: Artica notifier notifications are not enabled
Starting......: verify iptables tables...
Starting......: iptables is disabled...
Starting......: daemon monitor Already running PID 3639

[root@LinuxArtica ~]# cat /usr/share/artica-postfix/ressources/settings.inc|grep KINIT_INSTALLED
$_GLOBAL["KINIT_INSTALLED"]=False;
[root@LinuxArtica ~]#


I need to configure the krb5 file to work? because i simply reinstall artica, upgrade to spetial version, and try all this ... maybe i need to do something else?

Gonzalo.
--

Ing. Gonzalo Araujo C
MCSE, MCSA, MCSD, ITIL, CISSP, C|EH, LPI
SLM Sistemas - Ingenio Virtual
http://www.slmsistemas.com
Colombia - Guatemala - Chile - Venezuela
User avatar
garaujo
 
Posts: 31
Joined: Sun Sep 12, 2010 4:58 pm
Location: Caracas / Venezuela
Artica servers number: 10
Linux System: CentOS
Technical skills: A Linux developper

Re: Artica with cyrus-imap validating against Active Directory

New postby admin » Sat Oct 16, 2010 3:51 pm

shit CentOS !!!

/usr/kerberos/bin/kinit

is not a "standard" way to install binaries !!!

binaries location should be in /bin /usr/sbin /usr/local/bin /usr/local/sbin not /usr/kerberos/bin !!!

i must send to you a new nightly build
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Artica with cyrus-imap validating against Active Directory

New postby garaujo » Sat Oct 16, 2010 3:57 pm

hehehhee ... lol :D .... agree with that ...
--

Ing. Gonzalo Araujo C
MCSE, MCSA, MCSD, ITIL, CISSP, C|EH, LPI
SLM Sistemas - Ingenio Virtual
http://www.slmsistemas.com
Colombia - Guatemala - Chile - Venezuela
User avatar
garaujo
 
Posts: 31
Joined: Sun Sep 12, 2010 4:58 pm
Location: Caracas / Venezuela
Artica servers number: 10
Linux System: CentOS
Technical skills: A Linux developper

Re: Artica with cyrus-imap validating against Active Directory

New postby admin » Sat Oct 16, 2010 4:16 pm

try the 1.4.101617 version
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Artica with cyrus-imap validating against Active Directory

New postby admin » Thu Oct 21, 2010 12:10 am

any news ?
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Artica with cyrus-imap validating against Active Directory

New postby garaujo » Thu Oct 21, 2010 1:29 am

Hello David, yes, in my lab this work great ... tomorow i will go to one of our clients to implement this solution and will post here the result in a production environment.

Thanks ;)
--

Ing. Gonzalo Araujo C
MCSE, MCSA, MCSD, ITIL, CISSP, C|EH, LPI
SLM Sistemas - Ingenio Virtual
http://www.slmsistemas.com
Colombia - Guatemala - Chile - Venezuela
User avatar
garaujo
 
Posts: 31
Joined: Sun Sep 12, 2010 4:58 pm
Location: Caracas / Venezuela
Artica servers number: 10
Linux System: CentOS
Technical skills: A Linux developper

Re: Artica with cyrus-imap validating against Active Directory

New postby garaujo » Fri Oct 22, 2010 11:56 pm

Everything good david ... i still need to change the cyrus password using the interface, and create a cyrus user in the AD ...

Good Job ;)

My client ask if there is some way to sync deleted users too ... i mean .. what happen if a user is erased in the active directory ... the user can't log on of course, but the mailbox still there until manual verification ... maybe we can have a button for two way sync or something? and alert and ask what to do ?

Greetings.
--

Ing. Gonzalo Araujo C
MCSE, MCSA, MCSD, ITIL, CISSP, C|EH, LPI
SLM Sistemas - Ingenio Virtual
http://www.slmsistemas.com
Colombia - Guatemala - Chile - Venezuela
User avatar
garaujo
 
Posts: 31
Joined: Sun Sep 12, 2010 4:58 pm
Location: Caracas / Venezuela
Artica servers number: 10
Linux System: CentOS
Technical skills: A Linux developper

Re: Artica with cyrus-imap validating against Active Directory

New postby admin » Sat Oct 23, 2010 1:23 am

yes it is possible to perform a verification task
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

PreviousNext

Return to Cyrus-imap

Who is online

Users browsing this forum: No registered users and 1 guest

cron