Erreur cyrus: DBERROR db4 [FIXED]

Questions et support sur le cyrus-imap géré par Artica...

Erreur cyrus: DBERROR db4 [FIXED]

New postby valentin » Fri Oct 08, 2010 10:05 am

Bonjour,

J'ai remarqué plusieurs fois des problèmes sur cyrus après des mises à jour de ubuntu vers la 10.04.
La messagerie ne fonctionne plus et après une certain nombre d'opérations via artica-install cyrus a toujours réussi à redémarrer.

Je m'attend cependant à voir réapparaitre cette erreur.

De ce que j'en ai compris, il y a un problème entre la version de libdb utilisée par artica (libd4.6) et les versions installées sur le systeme suite à la mise a jour ( libdb4.7 ou libdb4.8)

Existe-t-il une solution pour coupler artica avec les dernière versions de libdb?

Je doit avoir des logs si cela vous permet de m'aider sur ce problème.

Cordialement.
valentin
 
Posts: 17
Joined: Mon May 17, 2010 2:53 pm
Artica servers number: 11
Linux System: Ubuntu
Technical skills: A Geek

Re: Erreur cyrus: DBERROR db4

New postby admin » Fri Oct 08, 2010 11:05 am

IL existe des outils comme db4.8_upgrade qui permettent de mettre à jour les bases berkley
il suffit de les lancer afin de rendre conforme les bases mails avec ce que demande cyrus
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Erreur cyrus: DBERROR db4

New postby valentin » Fri Oct 08, 2010 2:35 pm

Merci pour votre réponse rapide.
Je me suis aperçu qu'il manquait le paquet lidb4.8-dev. :?
Après installation tout fonctionne correctement.

Merci de votre patience.
valentin
 
Posts: 17
Joined: Mon May 17, 2010 2:53 pm
Artica servers number: 11
Linux System: Ubuntu
Technical skills: A Geek


Return to cyrus-imap

Who is online

Users browsing this forum: No registered users and 2 guests

cron