Login error [CLOSED]

All about Artica managing samba daemons

Login error [CLOSED]

New postby abolinhas » Tue Oct 13, 2009 7:48 pm

I can not login user in windows xp, I already add the machine to the domain, but when I try login I get this message

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.

DETAIL - The network name cannot be found.


Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.


I can only login with administrator
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby jamlydm » Wed Oct 14, 2009 12:16 am

If you are using the default profile folder: "/home/export/profile"

please verify that your users have the chmod permision to enter to their own folder.
chmod.JPG
chmod.JPG (48.73 KiB) Viewed 8433 times


If your username is "user1", use this:

Code: Select all
chmod 755 /home/export/profile/user1
, where "user1" is his/her folder.

If you have another samba or windows domain, be sure that your Artica server has the highest value in the samba settings "OS level = 40" to be the PDC "Primary Domain Controller" and your Windows Client can see it in the network. This option is set in Artica in the Menu "File Sharings -> Samba Shares Engine -> Domain Controler or Single Server ", option "Simulate Operating system"
jamlydm
 
Posts: 278
Joined: Thu Jul 23, 2009 3:57 pm
Artica servers number: 1
Linux System: Debian
Technical skills: Microsoft Windows skills

Re: Login error

New postby abolinhas » Thu Oct 15, 2009 3:32 pm

Hi Jamlydm / David

I upgrade artica to last nightly build (1.3.101412) and I disable roaming profiles.
I put Samba OS Level = 40
User premission are OK
Code: Select all
srvfile:/home# ls -l
drwxr-xr-x 3 test          root 4096 Oct 15 16:00 test


But I still can not login in windows, same error message

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.

DETAIL - The network name cannot be found.


Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby admin » Fri Oct 16, 2009 10:51 am

you need to unlink from domain and to re-link after disable roaming feature.
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Login error

New postby abolinhas » Fri Oct 16, 2009 10:57 am

Hi David,

I did this, in fact, I reinstall Artica and upgrade to 1.3.101412, then I disable roaming profiler, then I reinstall windows xp, then I join windows xp to the domian, but don´t work :(
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby admin » Fri Oct 16, 2009 1:27 pm

Wich don't work, linking to the domain or disable roaming profile ?
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Login error

New postby abolinhas » Fri Oct 16, 2009 2:06 pm

Hi David,

Both worked, I can join the machine to the domain and I can disable roaming profiles, which is I can not do is log user into windows xp.
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby admin » Fri Oct 16, 2009 4:20 pm

you mean that you can set username and password into windows session on the Windows computer ?
User avatar
admin
Site Admin
 
Posts: 11943
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Login error

New postby abolinhas » Fri Oct 16, 2009 4:31 pm

Yes, but during the user login I get this error message

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.

DETAIL - The network name cannot be found.


Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby jamlydm » Fri Oct 16, 2009 4:59 pm

Please verify the following:

The user permission is in "/home/export/profile", not in "/home".
When you log on, your Windows try to load or copy the user profile in the "/home/export/profile". Artica Samba Settings config the profile folder there.

Please execute this:
Code: Select all
chmod 755 /home/export/profile/test


After that, verify this:

Code: Select all
srvfile:/home/export/profile# ls -l
drwxr-xr-x 3 test          root 4096 Oct 15 16:00 test


Restart your windows and try again.

I think the OS level its not the problem in your server. I forget to explain you this:

Artica by default has OS LEVEL = 34. In my case i have a production artica server and a test artica server. Both Artica are PDC. My main PDC has OS Level = 40 but the another has the default "OS Level = 34". OS LEVEL should be the highest when you have two or more domain servers in your network. Please read this http://web.mit.edu/rhel-doc/OldFiles/4/RH-DOCS/rhel-rg-es-4/s1-samba-network-browsing.html
Last edited by jamlydm on Fri Oct 16, 2009 5:29 pm, edited 1 time in total.
jamlydm
 
Posts: 278
Joined: Thu Jul 23, 2009 3:57 pm
Artica servers number: 1
Linux System: Debian
Technical skills: Microsoft Windows skills

Next

Return to Samba discuss

Who is online

Users browsing this forum: No registered users and 1 guest

cron