Login error [CLOSED]

All about Artica managing samba daemons

Re: Login error

New postby abolinhas » Fri Oct 16, 2009 5:27 pm

I don´t have any user in /home/export/profile.
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby jamlydm » Fri Oct 16, 2009 8:20 pm

OK.
When you Enable the "Roaming Profiles". By default the users folder are saved in "/home/export/profile".

My Samba Configuration script (enter to the "File Sharing Menu", select samba engines and after "Configuration script") has:

Code: Select all
[netlogon]
path = /home/netlogon
writable = No
browseable = No
write list = root

[profiles]
#see USERENV.LOG in c:\windows\debug\UserMod on Windows XP for troubleshooting
path = /home/export/profile
oplocks = false
level2 oplocks = false
csc policy = disable
browseable = No
writeable = Yes
read only = No
profile acls = yes
create mask = 0600
store dos attributes = yes
directory mask = 0700
comment = Roaming user profile storage

[profiles.V2]
copy = profiles
browseable = no

[homes]
comment = Personnal Folder
browseable = No
writeable = Yes



When i enter to the menu "Organization -> Manage UsersGroups " select the Group where i saved Artica users, click Members, clic add user, add the user information, Artica creates 2 folder. 1 folder in "/home" and another folder in "/home/export/profile".
jamlydm
 
Posts: 278
Joined: Thu Jul 23, 2009 3:57 pm
Artica servers number: 1
Linux System: Debian
Technical skills: Microsoft Windows skills

Re: Login error

New postby abolinhas » Fri Oct 16, 2009 9:18 pm

I dont have roaming profiles enable:

My smb.conf
Code: Select all
[global]
workgroup = arqacademy.lan
netbios name = srvfile
server string = %h server
disable netbios =no
syslog = 3
log level = 0
log file = /var/log/samba/log.%m
debug timestamp = yes


# Controler ?? -----------------------------------
security = user
enable privileges = yes
domain master = yes
local master = yes
preferred master = yes
domain logons = yes
os level = 40
printer admin = root,administrator,@Administrators,@lpadmin
ldap passwd sync = no


#VISTA/Windows7 compatibility
client lanman auth = no
client ntlmv2 auth = yes


# LDAP settings -----------------------------------
ldap delete dn = no
passdb backend = ldapsam:ldap://127.0.0.1:389


#scripts -----------------------------------
add machine script = /usr/share/artica-postfix/bin/artica-install --samba-add-computer "%u"
ldap admin dn = cn=admin,dc=nodomain
ldap suffix = dc=nodomain
ldap group suffix = ou=groups,dc=samba,dc=organizations
ldap user suffix = ou=users,dc=samba,dc=organizations
ldap machine suffix = ou=Computer,dc=samba,dc=organizations
ldap ssl = no
logon script = script.bat
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
case sensitive = No
default case = lower
preserve case = yes
short preserve case = yes


#character set = iso8859-1


#domain admin group = @admin
dns proxy = No
wins support = Yes


#hosts allow = 192.168.0. 127.
winbind use default domain = yes
winbind enum users = yes
winbind enum groups = yes
nt acl support = yes
map acl inherit = yes

# Need Extended Attributes on the local file system
store dos attribute = yes

# Need Extended Attributes on the local file system
time server = yes


#MDFS parameters
msdfs root = no
host msdfs = no


# Shared Folders lists -----------------------------------

[netlogon]
path = /home/netlogon
writable = No
browseable = No
write list = root

[homes]
comment = Personnal Folder
browseable = No
writeable = Yes

[printers]
comment = Printers
browseable = yes
path = /tmp
printable = yes
public = yes
guest ok = yes
writable = no
create mode = 0700

[print$]
comment = Printers drivers
path = /etc/samba/printer_drivers
browseable = yes
guest ok = no
read only = yes
write list = root,administrator,@Administrators,@lpadmin
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby jamlydm » Mon Oct 19, 2009 4:31 pm

David did some changes, try updating to Artica 1.3.101911 and will be fixed.
jamlydm
 
Posts: 278
Joined: Thu Jul 23, 2009 3:57 pm
Artica servers number: 1
Linux System: Debian
Technical skills: Microsoft Windows skills

Re: Login error

New postby abolinhas » Mon Oct 19, 2009 4:58 pm

Hi,

I upgrade to the new version, but don´t work, same error message.

I unlink station from domain and link again, but don´t work.

Now I have users in /home/export/profile.
Code: Select all
srvfile:/home/export/profile# ls -l
total 12
drwxrwxr-x 2 administrator root 4096 Oct 18 03:10 administrator
drwxrwxr-x 2 andre         root 4096 Oct 19 18:29 andre
drwxrwxr-x 2 test          root 4096 Oct 18 03:10 test


I only can login with domain administrator, with domian user no.
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby admin » Mon Oct 19, 2009 5:15 pm

i don't understand why.
glade to receive your vmware virtual machine
User avatar
admin
Site Admin
 
Posts: 11944
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Login error

New postby abolinhas » Mon Oct 19, 2009 5:26 pm

Hi David,

I am now uploading the vmware image to my server, then I send you the download link via private message.
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

Re: Login error

New postby jamlydm » Mon Oct 19, 2009 7:16 pm

samba.JPG
samba.JPG (43.64 KiB) Viewed 5199 times
roaming.JPG
roaming.JPG (22.14 KiB) Viewed 5199 times


I try with Roaming profiles disabled and didnt work. In my case work only with roaming profiles enabled and rebuilding the settings.
jamlydm
 
Posts: 278
Joined: Thu Jul 23, 2009 3:57 pm
Artica servers number: 1
Linux System: Debian
Technical skills: Microsoft Windows skills

Re: Login error

New postby admin » Mon Oct 19, 2009 7:24 pm

I have found that even the profile is deleted under samba section, it is enable under the user account...
User avatar
admin
Site Admin
 
Posts: 11944
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Login error

New postby abolinhas » Mon Oct 26, 2009 1:49 pm

Hi,

I upgrade to 1.3.102402,but the problem with the login continues :cry:

Now I get a new error message.
Code: Select all
Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.

DETAUL - The filename, directoty name or volume label syntax is incorrect.


I do not understand why this give me an error of roaming profiles, because I do not have roaming profile enabled
Cumprimentos / Best Regards

André Bolinhas
Twitter: @abolinhas
User avatar
abolinhas
 
Posts: 1015
Joined: Fri Jun 19, 2009 8:50 am
Location: Portugal
Artica servers number: 4
Linux System: Ubuntu
Technical skills: A Linux System Administrator

PreviousNext

Return to Samba discuss

Who is online

Users browsing this forum: No registered users and 1 guest

cron