HotSpot error creating rules

discuss about artica with HTTP proxy products (Squid,squidguard, clamav...)

HotSpot error creating rules

New postby arkolo » Wed Mar 23, 2016 1:13 pm

I have a problem configuring an artica hotspot server
artica free version 2.36 -> updated to 2.38
2 network interface, lan interface and wan interface

i activated hotspot system without problem, but creating a rule for authentication purpose on local database, when i apply the rule the system return an error:

Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in /usr/share/artica-postfix/ressources/class.wifidog.settings.inc on line 54

and then reset the rules to default with no option configured.

any idea how to resolv the issue? i'm stuck and i cannot authenticate on the captive portal

thanks
arkolo
 
Posts: 4
Joined: Wed Mar 23, 2016 1:01 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A Linux System Administrator

Re: HotSpot error creating rules

New postby admin » Wed Mar 23, 2016 1:29 pm

Try to see if the dedicated MySQL service is running and Up

on the system, do

Code: Select all
/etc/init.d/squid-db restart
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: HotSpot error creating rules

New postby arkolo » Wed Mar 23, 2016 4:48 pm

yes it's running and i can browse the database

but when i do the restart:

Stopping......: 17:45:46 [INIT]: MySQL daemon (squid-db) already stopped...
Starting......: 17:45:46 [INIT]: squid-db ProxyUseArticaDB=0
Starting......: 17:45:46 [INIT]: squid-db is disabled...
Stopping......: 17:45:46 [INIT]: MySQL daemon (squid-db) already stopped...

in the mysql page on the portal i can browse the database and all seems running

articamysql.jpg
articamysql.jpg (242.73 KiB) Viewed 4302 times
arkolo
 
Posts: 4
Joined: Wed Mar 23, 2016 1:01 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A Linux System Administrator

Re: HotSpot error creating rules

New postby admin » Wed Mar 23, 2016 10:21 pm

When installing trough the ISO or using ou Virtual Appliance, the squid-db daemon is enabled by default.
Did you have installed the Artica manually ?
Or when using the ISO or Virtual Appliance, did you have added only 1 CPU for the machine ?
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: HotSpot error creating rules

New postby arkolo » Thu Mar 24, 2016 11:26 am

i've installed it trough the ISO on a VMWARE virtual machine

during the install there was only 1 CPU configured on the VM, after the installing i've added a second CPU

now the VM is configured with 2 CPU e 5GB RAM
arkolo
 
Posts: 4
Joined: Wed Mar 23, 2016 1:01 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A Linux System Administrator

Re: HotSpot error creating rules

New postby admin » Thu Mar 24, 2016 12:52 pm

This why Artica did not installed the dedicated service, the CPU number was too low and Artica have decided to not install this service.
Could you do this:

Code: Select all
/etc/init.d/mysql restart --force --framework=byhand
User avatar
admin
Site Admin
 
Posts: 11946
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: HotSpot error creating rules

New postby arkolo » Fri Mar 25, 2016 4:29 pm

thanks for the kindly help

I've executed the command:

Code: Select all
/etc/init.d/mysql restart --force --framework=byhand
Stopping MySQL...............: 2 memory tables to dump
Stopping MySQL...............: killing smoothly PID 28811
Stopping MySQL...............: Stopped
Starting......: 17:25:13 MySQL, apply permissions on artica_backup
Starting......: 17:25:13 MySQL, apply permissions on artica_events
Starting......: 17:25:13 MySQL, apply permissions on articameta
Starting......: 17:25:13 MySQL, apply permissions on eyeOS
Starting......: 17:25:13 MySQL, apply permissions on mysql
Starting......: 17:25:13 MySQL, apply permissions on performance_schema
Starting......: 17:25:13 MySQL, apply permissions on postfilter
Starting......: 17:25:13 MySQL, apply permissions on powerdns
Starting......: 17:25:13 MySQL, apply permissions on roundcubemail
Starting......: 17:25:13 MySQL, apply permissions on snort
Starting......: 17:25:13 MySQL, apply permissions on squidlogs
Starting......: 17:25:13 MySQL, apply permissions on syslogstore
Starting......: 17:25:13 MySQL, apply permissions on vmail
Starting......: 17:25:13 MySQL Pid path.......:/var/run/mysqld/mysqld.pid
Starting......: 17:25:13 datadir..............:/var/lib/mysql
Starting......: 17:25:13 Log error............:/var/lib/mysql/mysqld.err
Starting......: 17:25:13 socket...............:/var/run/mysqld/mysqld.sock
Starting......: 17:25:13 user.................:mysql
Starting......: 17:25:13 LOGS ENABLED.........:0
Starting......: 17:25:13 Daemon...............:/usr/sbin/mysqld
Starting......: 17:25:13 Bind address.........:127.0.0.1
Starting......: 17:25:13 Temp Dir.............:
Starting......: 17:25:13 innodb_force_recovery:0
Starting......: 17:25:13 Settings permissions..
Starting......: 17:25:14 MySQL Checking : /var/lib/mysql/mysql/host.frm
Starting......: 17:25:14 MySQL Checking : /var/lib/mysql/mysql/host.frm OK
Starting......: 17:25:14 MySQL `/usr/sbin/mysqld` 370 available option(s)
Starting......: 17:25:14 MySQL Option: /usr/sbin/mysqld
Starting......: 17:25:14 MySQL Option: --no-defaults --user=mysql
Starting......: 17:25:14 MySQL Option: --pid-file=/var/run/mysqld/mysqld.pid
Starting......: 17:25:14 MySQL Option: --log-error=/var/lib/mysql/mysqld.err
Starting......: 17:25:14 MySQL Option:
Starting......: 17:25:14 MySQL Option: --socket=/var/run/mysqld/mysqld.sock
Starting......: 17:25:14 MySQL Option: --datadir="/var/lib/mysql"
Starting......: 17:25:14 MySQL Option: --key-buffer-size=16K --max-allowed-packet=1M --tmp-table-size=4M --table-open-cache=4 --sort-buffer-size=64k --net-buffer-length=2K
Starting......: 17:25:14 MySQL Option: >/dev/null 2>&1 &
Starting......: 17:25:14 MySQL Starting daemon, please wait
Starting......: 17:25:16 MySQL Checks daemon running...
Starting......: 17:25:16 MySQL Checks mysqld.sock waiting 0/3
Starting......: 17:25:16 MySQL Success pid 31289
Starting......: 17:25:16 MySQL restoring memory tables
Starting......: 17:25:16 MySQL `/usr/bin/mysql --batch --force --protocol=socket --socket=/var/run/mysqld/mysqld.sock -u root -ppppppppp squidlogs  < /home/artica/MySQLStartStop/restore.sql 2>&1`


but nothing changed, the error still the same
and the squid-db still disabled:

Code: Select all
/etc/init.d/squid-db restart
Stopping......: 17:26:24 [INIT]: MySQL daemon (squid-db) already stopped...
Starting......: 17:26:24 [INIT]: squid-db ProxyUseArticaDB=0
Starting......: 17:26:24 [INIT]: squid-db is disabled...
Stopping......: 17:26:24 [INIT]: MySQL daemon (squid-db) already stopped...


i will try to reinstall the VM with 2 CPU
arkolo
 
Posts: 4
Joined: Wed Mar 23, 2016 1:01 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A Linux System Administrator


Return to Squid & Web filtering

Who is online

Users browsing this forum: No registered users and 6 guests

cron