DHCP starting problems

discuss about artica with HTTP proxy products (Squid,squidguard, clamav...)

DHCP starting problems

New postby bluescreen » Thu Mar 31, 2016 11:02 am

Hello ive a problem with artica.
I cant start Dhcp.

My artica version is the newest.

My configuration:

eth0:
ip: 192.168.0.6
netmask: 255.0.0.0
gateway: 0.0.0.0


dhcp:
From IP Address:
192.168.0.50

To IP Address:
192.168.0.230

Subnet:
192.168.0.0

Netmask:
255.0.0.0

Gateway:
192.168.0.6

Broadcast:
192.168.0.255

DNS Server 1:
192.168.0.4


Dhcplog:

Code: Select all
110% {starting_service}  {failed}
Starting......: 11:01:37 [INIT]: `/usr/sbin/dhcpd -q -pf /var/run/dhcpd.pid -cf /etc/dhcp3/dhcpd.conf -lf /var/lib/dhcp3/dhcpd.leases`
Starting......: 11:01:37 [INIT]: DHCP Server service failed...
Starting......: 11:01:36 [INIT]: DHCP Server service waiting 5/6...
80% {starting_service}  waiting 5/6
Starting......: 11:01:34 [INIT]: DHCP Server service waiting 4/6...
80% {starting_service}  waiting 4/6
Starting......: 11:01:32 [INIT]: DHCP Server service waiting 3/6...
80% {starting_service}  waiting 3/6
Starting......: 11:01:30 [INIT]: DHCP Server service waiting 2/6...
80% {starting_service}  waiting 2/6
Starting......: 11:01:28 [INIT]: DHCP Server service waiting 1/6...
80% {starting_service}  waiting 1/6
Starting......: 11:01:26 [INIT]: DHCP Server service waiting 0/6...
80% {starting_service}  waiting 0/6
80% {starting_service}
Starting......: 11:01:24 [INIT]: DHCP Server service..
75% {starting_service}
70% {starting_service}
Starting......: 11:01:21 [INIT]: DHCP Server saving "/etc/dhcp3/dhcpd.conf" (1356 bytes) done
Starting......: 11:01:21 [INIT]: DHCP Server server domain name server 1]:192.168.0.4
Starting......: 11:01:21 [INIT]: DHCP Server server PXE enabled ? "0"
Starting......: 11:01:21 [INIT]: DHCP Server Subnet Range ......: 192.168.0.50 - 192.168.0.230
Starting......: 11:01:21 [INIT]: DHCP Server Subnet Range 1.....: 192.168.0.50
Starting......: 11:01:21 [INIT]: DHCP Server Subnet final_subnet: 192.168.0.0
Starting......: 11:01:21 [INIT]: DHCP Server Subnet 192 - 168 - 0
65% {starting_service}
Starting......: 11:01:20 [INIT]: DHCP Server building settings...
Starting......: 11:01:20 [INIT]: DHCP Server Listen eth1
60% {starting_service}
50% {starting_service}
70% {starting_service}
Starting......: 11:01:16 [INIT]: DHCP Server saving "/etc/dhcp3/dhcpd.conf" (1356 bytes) done
Starting......: 11:01:16 [INIT]: DHCP Server server domain name server 1]:192.168.0.4
Starting......: 11:01:16 [INIT]: DHCP Server server PXE enabled ? "0"
Starting......: 11:01:16 [INIT]: DHCP Server Subnet Range ......: 192.168.0.50 - 192.168.0.230
Starting......: 11:01:16 [INIT]: DHCP Server Subnet Range 1.....: 192.168.0.50
Starting......: 11:01:16 [INIT]: DHCP Server Subnet final_subnet: 192.168.0.0
Starting......: 11:01:16 [INIT]: DHCP Server Subnet 192 - 168 - 0
65% {starting_service}
50% {reconfigure_service}
Stopping......: 11:01:14 [INIT]: DHCP Server service already stopped...
10% {stopping_service}
bluescreen
 
Posts: 2
Joined: Thu Mar 31, 2016 10:53 am
Artica servers number: 1
Linux System: Debian
Technical skills: A newbee

Re: DHCP starting problems

New postby admin » Thu Mar 31, 2016 4:39 pm

can you extract this information

Code: Select all
grep dhcp /var/log/syslog >/root/dhcp.txt
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: DHCP starting problems

New postby bluescreen » Thu Mar 31, 2016 5:41 pm

Thats the result:
Code: Select all
Mar 30 10:26:33 articaproxy dhcpd: Copyright 2004-2011 Internet Systems Consortium.
Mar 30 10:26:33 articaproxy dhcpd: All rights reserved.
Mar 30 10:26:33 articaproxy dhcpd: Usage: dhcpd [-p <UDP port #>] [-f] [-d] [-q] [-t|-T]#012             [-4|-6] [-cf config$
Mar 30 11:18:12 articaproxy dhcpd: Internet Systems Consortium DHCP Server 4.2.2
Mar 30 11:18:12 articaproxy dhcpd: Copyright 2004-2011 Internet Systems Consortium.
Mar 30 11:18:12 articaproxy dhcpd: All rights reserved.
Mar 30 11:18:12 articaproxy dhcpd: Usage: dhcpd [-p <UDP port #>] [-f] [-d] [-q] [-t|-T]#012             [-4|-6] [-cf config$
Mar 30 11:18:39 articaproxy class.unix.inc[46613]: ToSyslog(){3791} SystemIsUserIngroup `dhcpd` is not a member of `dhcpd`..$
Mar 30 11:18:39 articaproxy class.unix.inc[46613]: ToSyslog(){3791} Warning, want to chown user: `dhcpd` group:`dhcpd` inval$
Mar 30 11:18:39 articaproxy class.unix.inc[46613]: ToSyslog(){3791} Adding user `dhcpd` to group `dhcpd`
Feb  5 05:54:42 articaproxy dhcpd: Internet Systems Consortium DHCP Server 4.2.2
Feb  5 05:54:42 articaproxy dhcpd: Copyright 2004-2011 Internet Systems Consortium.
Feb  5 05:54:42 articaproxy dhcpd: All rights reserved.
Feb  5 05:54:42 articaproxy dhcpd: Usage: dhcpd [-p <UDP port #>] [-f] [-d] [-q] [-t|-T]#012             [-4|-6] [-cf config$
Feb  5 05:57:07 articaproxy dhcpd: Internet Systems Consortium DHCP Server 4.2.2
Feb  5 05:57:07 articaproxy dhcpd: Copyright 2004-2011 Internet Systems Consortium.
Feb  5 05:57:07 articaproxy dhcpd: All rights reserved.
Feb  5 05:57:07 articaproxy dhcpd: Usage: dhcpd [-p <UDP port #>] [-f] [-d] [-q] [-t|-T]#012             [-4|-6] [-cf config$
Mar 30 10:26:33 articaproxy dhcpd: Internet Systems Consortium DHCP Server 4.2.2
bluescreen
 
Posts: 2
Joined: Thu Mar 31, 2016 10:53 am
Artica servers number: 1
Linux System: Debian
Technical skills: A newbee

Re: DHCP starting problems

New postby admin » Thu Mar 31, 2016 9:23 pm

can you run this command line and post the output

Code: Select all
/usr/sbin/dhcpd -q -pf /var/run/dhcpd.pid -cf /etc/dhcp3/dhcpd.conf -lf /var/lib/dhcp3/dhcpd.leases
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France


Return to Squid & Web filtering

Who is online

Users browsing this forum: No registered users and 1 guest

cron