Setting up Squid 3.1.xTransparent Proxy Centos 6.7 [CLOSED]

discuss about artica with HTTP proxy products (Squid,squidguard, clamav...)

Setting up Squid 3.1.xTransparent Proxy Centos 6.7 [CLOSED]

New postby hsotnas » Mon May 23, 2016 2:35 pm

Hello Folks,

Need help in setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 with 2 NICs.

Here are my setup details...

Centos 6.7 (64bit) running on Hyper-V VM

eth0 is connected to WAN and eth1 is connected to LAN network

eth0 :
ip = 10.218.104.146
mask = 255.255.254.0
gw = 10.218.103.1
dns =10.221.1.15 (Local DNS Server)
dns =10.221.1.16 (Local DNS Server)


eth1:
ip = 10.10.10.123
mask = 255.255.255.0
gw -No Gateway


My squid config file looks like below

# cat /etc/squid/squid.conf
#
# Recommended minimum configuration:
#
acl manager proto cache_object
acl localhost src 127.0.0.1/32 ::1
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines

#Local Area Network
acl lan src 10.10.10.0/24

#Allow LAN
http_access allow lan

#Hostname
visible_hostname master.mwdbcoe.net

acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

#
# Recommended minimum Access Permission configuration:
#
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager

# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#

# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 3128 transparent

# Uncomment and adjust the following to add a disk cache directory.
#cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320



I ran following commands, saved iptables rules and restarted the service

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j DNAT --to 10.10.10.123:3128

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

iptables -I INPUT -s 10.10.10.0/24 -p tcp --dport 3128 -j ACCEPT


I have used 10.10.10.123 as GW on a test machine (10.10.10.x subnet) to see the internet access but in vain.

What am I missing here? Any help would be appreciated.

P.S. I am fairly new to Linux world and learning things everyday. Kindly bear with me :)

Regards
hsotnas
 
Posts: 7
Joined: Mon May 23, 2016 2:32 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A newbee

Re: Setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 x64

New postby admin » Mon May 23, 2016 8:07 pm

this is a forum for the Artica Product that manages Squid.
I'm suggest to download the Artica ISO, is quite easy to create a transparent proxy using Artica
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 x64

New postby hsotnas » Tue May 24, 2016 3:03 am

Thank you.

I will download the ISO and give it a go.

I will post questions here, if I need help :)

Thanks again.
hsotnas
 
Posts: 7
Joined: Mon May 23, 2016 2:32 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A newbee

Re: Setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 x64

New postby hsotnas » Tue May 24, 2016 8:31 am

I have installed artica-proxy on a VM using latest ISO. I could manage to complete the initial configuration and chose "artica web proxy or transparent proxy" as a service and I can now see web interface.

But when I try to log on using username 'Manager' and password (which I have specified in the console), I get wrong username or password error!

How do I fix it?

artica-error.jpg
artica-error.jpg (75.58 KiB) Viewed 3478 times


P.S. I am specifying the correct password which I have set in the console. I have even rebooted the VM to if it makes a difference but in vain.
hsotnas
 
Posts: 7
Joined: Mon May 23, 2016 2:32 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A newbee

Re: Setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 x64

New postby hsotnas » Tue May 24, 2016 9:53 am

Well, I figured it out and I could log on to artica-proxy web ui.

Followed the article: http://artica-proxy.com/installation-wi ... p-by-step/

had to use secret as a default password to log on and then change the password. Earlier, I was trying to set password using console.

Now that I am able to log on, I am unable to find an option to configure transparent proxy option as stated in following link.

http://artica-proxy.com/proxy-transparent-mode/

I have installed artica proxy from "artica-proxy-2.36.020502.hdx.zip" hyper-v image.

https://sourceforge.net/projects/artica ... es/HyperV/


BTW, following is my network config

eth0 Link encap:Ethernet HWaddr 00:15:5d:0a:0b:45
inet addr:10.217.103.148 Bcast:10.217.103.255 Mask:255.255.254.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:99653 errors:0 dropped:1 overruns:0 frame:0
TX packets:47265 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:105913558 (101.0 MiB) TX bytes:3896285 (3.7 MiB)

eth1 Link encap:Ethernet HWaddr 00:15:5d:0a:0b:46
inet addr:10.10.10.199 Bcast:10.10.10.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:42736 errors:0 dropped:0 overruns:0 frame:0
TX packets:45585 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6969062 (6.6 MiB) TX bytes:22818764 (21.7 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.255.255.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:128731 errors:0 dropped:0 overruns:0 frame:0
TX packets:128731 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:108701719 (103.6 MiB) TX bytes:108701719 (103.6 MiB)



I would like to access Internet on the LAN machines which have IPs in the range 10.10.10.x/24 subnet and this subnet has no gateway.

Please help.
hsotnas
 
Posts: 7
Joined: Mon May 23, 2016 2:32 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A newbee

Re: Setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 x64

New postby admin » Tue May 24, 2016 10:12 am

if computers have no gateway, they did not know where to go for addresses that are not in 10.10.10.0/24
when trying to get an address such as 216.239.38.120 they will say "Network Inreachable"
you must specify the proxy as gateway for these computers
And you did not need 2 network interfaces to make the transparent to work, only 1 nic do the job
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Setting up Squid 3.1.23 Transparent Proxy on Centos 6.7 x64

New postby hsotnas » Tue May 24, 2016 11:41 am

Thanks so much for the reply.

I was in a desperate need of setting up proxy for my Lab. I managed to setup a web proxy following your great video on youtube.

https://www.youtube.com/watch?v=B7RNa_s-XIQ

I cannot thank you enough. You are a savior.

You may please close this thread.

Cheers
hsotnas
 
Posts: 7
Joined: Mon May 23, 2016 2:32 pm
Artica servers number: 1
Linux System: CentOS
Technical skills: A newbee


Return to Squid & Web filtering

Who is online

Users browsing this forum: No registered users and 5 guests

cron