clamd not starting - disabled by EnableClamavDaemon [FIXED]

Discuss about milter-clamav, clamav, clamd

clamd not starting - disabled by EnableClamavDaemon [FIXED]

New postby rjanowsky » Wed Jun 19, 2013 7:22 am

The clamav plugin is enabled in the config, but clamd won't start:
---------------------------------------------------------------------------

root@mail:~# /etc/init.d/artica-postfix start clamd --verbose
###################### CLAMAV ######################
PROCESS_EXIST(): -> checks if exists...
PROCESS_EXIST(): not an integer
Starting......: clamav daemon is disabled by EnableClamavDaemon token...
Starting......: clamav daemon is disabled by EnableClamavDaemon token...

Regards

Ronald
--
rjanowsky
 
Posts: 7
Joined: Wed Jun 19, 2013 7:03 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: clamd not starting - disabled by EnableClamavDaemon

New postby admin » Wed Jun 19, 2013 7:38 am

Yes, because clamav only start if its required.
For example, if you have enabled Amavis
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: clamd not starting - disabled by EnableClamavDaemon

New postby rjanowsky » Wed Jun 19, 2013 7:42 am

amavisd-new is configured and running - see attached screenshot.
Attachments
clamd-01.png
Screenshot
clamd-01.png (100.26 KiB) Viewed 5056 times
rjanowsky
 
Posts: 7
Joined: Wed Jun 19, 2013 7:03 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: clamd not starting - disabled by EnableClamavDaemon

New postby admin » Wed Jun 19, 2013 8:14 am

run this

(i think it is a memory issue)

echo 1 >/etc/artica-postfix/settings/Daemon/EnableClamavDaemon
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: clamd not starting - disabled by EnableClamavDaemon

New postby rjanowsky » Wed Jun 19, 2013 9:14 am

I already did this today in the morning:
----------------------------------------------

root@mail:~# ls -lh /etc/artica-postfix/settings/Daemons/EnableClamavDaemon
-rw-r--r-- 1 root root 1 Jun 19 11:12 /etc/artica-postfix/settings/Daemons/EnableClamavDaemon
root@mail:~# cat /etc/artica-postfix/settings/Daemons/EnableClamavDaemon
1


But the problem stays the same:

Starting......: clamav daemon is disabled by EnableClamavDaemon token...
rjanowsky
 
Posts: 7
Joined: Wed Jun 19, 2013 7:03 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator

Re: clamd not starting - disabled by EnableClamavDaemon

New postby admin » Wed Jun 19, 2013 4:45 pm

This is strange because this token lock or unlock the setting
Anyway...
Apply this patch
do
Code: Select all
killall artica-install
tar -xf patch.tar.gz -C /usr/share/artica-postfix/
echo "1" > /etc/artica-postfix/settings/Daemons/EnableClamavDaemonForced


This will force to enable Clamav even it's think that EnableClamavDaemon is set to 0
Attachments
patch.tar.gz
(1.39 MiB) Downloaded 213 times
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: clamd not starting - disabled by EnableClamavDaemon

New postby rjanowsky » Thu Jun 20, 2013 5:19 am

The patch works and clamd was started via the new setting EnableClamavDaemonForced.

Thanks a lot for this very fast troubleshooting.

Regards,

Ronald
--
rjanowsky
 
Posts: 7
Joined: Wed Jun 19, 2013 7:03 am
Artica servers number: 1
Linux System: Debian
Technical skills: A Linux System Administrator


Return to Clamav

Who is online

Users browsing this forum: No registered users and 1 guest

cron