Unable to install amavisd-new (Scientific Linux 6.3)

Discuss about amavisd-new and milter-amavisd

Unable to install amavisd-new (Scientific Linux 6.3)

New postby dalco » Tue Sep 25, 2012 6:34 am

Artica v 1.6.092500 + Scientific Linux 6.3 minimal install

I tried to install amavisd-new from web-interface (Install or upgrade software->Software database) but without success. :(

After pressing on picture left from amavisd-new, system begin installation (increases CPU usage, starts animation and so on). After approximately 20-30 minutes of activities installation finished, but amavisd-new in list of software still not installed.

According to install log (in attachment) appears some problems with geoip (v 1.4.8) install. System already has own geoip package, but its version is older (v1.4.6) and no geoip-devel installed.

Any tips to install amavisd-new?
Attachments
APP_AMAVISD_NEW.log.gz
(10.62 KiB) Downloaded 301 times
--------------------------------------------------------
Sorry for engRish, I am bear from Siberia
dalco
 
Posts: 36
Joined: Fri Sep 07, 2012 6:01 am
Artica servers number: 1
Linux System: Debian
Technical skills: A newbee

Re: Unable to install amavisd-new (Scientific Linux 6.3)

New postby dalco » Wed Sep 26, 2012 5:00 am

This morning I installed fresh experimental geoip packages(1.4.8-1.el6) from http://koji.fedoraproject.org/koji/packageinfo?packageID=1201. Then installed latest available rhel amavisd-new.rpm(2.6.6-3.el6.rf) from rpmforge. Than chkconfig --levels 235 amavisd on and service amavisd start.

Well, amavisd-new is working now. It's good. But Artica still cannot see amavisd. It's bad. :mrgreen:

I think, that I something missed.
--------------------------------------------------------
Sorry for engRish, I am bear from Siberia
dalco
 
Posts: 36
Joined: Fri Sep 07, 2012 6:01 am
Artica servers number: 1
Linux System: Debian
Technical skills: A newbee

Re: Unable to install amavisd-new (Scientific Linux 6.3)

New postby admin » Wed Sep 26, 2012 9:33 pm

Artica checks only if exists

Code: Select all
/usr/local/sbin/amavisd
/usr/sbin/amavisd-new


do

Code: Select all
ln -s pathofamavisbin /usr/local/sbin/amavisd

and run
Code: Select all
/usr/share/artica-postfix/bin/process1 --force --verbose
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Unable to install amavisd-new (Scientific Linux 6.3)

New postby dalco » Thu Sep 27, 2012 3:44 am

Thanks! Seems, that amavisd working now.

Code: Select all
[root@orion ~]# ln -s /usr/sbinamavisd /usr/local/sbin/amavisd
[root@orion ~]# ln -s /etc/amavisd.conf /usr/local/etc/amavisd.conf
[root@orion ~]# /usr/share/artica-postfix/bin/process1 --force --verbose


May be on 2nd line was overkill. :)

P.S. Please, do some base checking for Artica on rhel-based distro. If Artica will work on rhel-based distro out of the box, it will greatly increase artica popularity.
--------------------------------------------------------
Sorry for engRish, I am bear from Siberia
dalco
 
Posts: 36
Joined: Fri Sep 07, 2012 6:01 am
Artica servers number: 1
Linux System: Debian
Technical skills: A newbee

Re: Unable to install amavisd-new (Scientific Linux 6.3)

New postby admin » Thu Sep 27, 2012 8:01 am

P.S. Please, do some base checking for Artica on rhel-based distro. If Artica will work on rhel-based distro out of the box, it will greatly increase artica popularity.

Artica live since 10 years and officially supports CentOS, Fedora, OpenSuSe that i consider these are redhat systems
99% of installed solutions are Debian/Ubuntu.
I means "of the world"
there is 10 204 servers in activity.
300 are redhat systems and 95% are centos the rest is OpenSuSe and fedora and .... your server in Scientific Linux (you are alone...)
5.000 came from ISO -> our ISO is debian so i not calculating these servers.
Where is the popularity ?
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: Unable to install amavisd-new (Scientific Linux 6.3)

New postby dalco » Thu Sep 27, 2012 10:59 am

admin wrote:Artica live since 10 years and officially supports CentOS, Fedora, OpenSuSe that i consider these are redhat systems
99% of installed solutions are Debian/Ubuntu.
I means "of the world"
there is 10 204 servers in activity.
300 are redhat systems and 95% are centos the rest is OpenSuSe and fedora and .... your server in Scientific Linux (you are alone...)
5.000 came from ISO -> our ISO is debian so i not calculating these servers.
Where is the popularity ?


Well, Scientific Linux is repainted RHEL. So if I cannot install something on SL, than I cannot install it on RHEL/CentOS too (with probability 99.99%).

Are you test Artica install on clean RHEL/CentOS 6.3 x64? Does clamav/amavisd/zarafa installing/working out of the box? I am afraid that Artica in non working state on last RHEL too.

P.S. And Artica doesn't work correctly on last Fedora at all (I lost week to try successfully start Artica on clean Fedora17 ). Artica cannot control Fedora services (for most services Fedora uses systemd instead of /etc/init.d)

P.P.S Please, don't interpret my post as newbies complain. It's just bug report in incorrect form;)
--------------------------------------------------------
Sorry for engRish, I am bear from Siberia
dalco
 
Posts: 36
Joined: Fri Sep 07, 2012 6:01 am
Artica servers number: 1
Linux System: Debian
Technical skills: A newbee

Re: Unable to install amavisd-new (Scientific Linux 6.3)

New postby admin » Thu Sep 27, 2012 7:31 pm

All is currently under fix dev....
Your feedbacks are very important....
User avatar
admin
Site Admin
 
Posts: 11942
Joined: Wed Oct 17, 2007 7:59 am
Location: France


Return to amavisd-new

Who is online

Users browsing this forum: No registered users and 1 guest

cron