demande d'aide de configuration

Artica se doit de gérer aussi le VPN, ici toutes les discussions concernant l'administration du serveur OpenVPN

demande d'aide de configuration

New postby Barman2010 » Sat Jan 16, 2010 2:18 pm

Bonjour,
Et bravo pour le boulot sur le projet Artica.

Voila j'ai installer un serveur Artica pour utiliser plusieurs de ces fonctions dont le VPN. Dans ce domaine je découvre car je n'ai jamais monté de vpn au par avant

J'ai configurer avevc l'aide mon serveur OpenVPN, j'ai bien configurer mon ip externe, mon interface eth0 et je nesuis pas en mode server.

Dans mon interface en front-end j'ai bien mon tun0

J'aimerai savoir comment configurer mes clients, sachant qu'ils sont sous vista et seven.
J'aimerai savoir aussi comment on leur creer des comptes pour utiliser le vpn

merci d'avance,

Christophe V.
Barman2010
 
Posts: 6
Joined: Fri Jan 15, 2010 8:45 pm
Artica servers number: 1
Linux System: Ubuntu
Technical skills: A Geek

Re: demande d'aide de configuration

New postby admin » Sat Jan 16, 2010 11:27 pm

il faut créer des utilisateurs et leur donner le privilège de groupe d'accès au VPN
http://www.artica.fr/index.php/artica-a ... tions-page

dans l'interface utilisateur final, vous aurez les liens pour utiliser le client VPN et pour télécharger le fichier de configuration du client.

vous pouvez aussi utiliser la nouvelle interface pour utilisateurs
http://www.artica.fr/index.php/artica-a ... your-users
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: demande d'aide de configuration

New postby Barman2010 » Mon Jan 18, 2010 11:40 am

Bonjour,

Merci pour les infos pour mes clients, maintenant je sais leur faire des comptes et mettres les droits pour le VPN

Une fois tout ceci fais en testant sur plusieurs machine j'obtient toujours ceci :

Code: Select all
Mon Jan 18 12:33:27 2010 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
Mon Jan 18 12:33:27 2010 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Mon Jan 18 12:33:27 2010 Cannot load certificate file *******.crt: error:02001002:system library:fopen:No such file or directory: error:20074002:BIO routines:FILE_CTRL:system lib: error:140AD002:SSL routines:SSL_CTX_use_certificate_file:system lib
Mon Jan 18 12:33:27 2010 Exiting


Ou est ce que j'ai merdé ? :)

Merci d'avance.
Barman2010
 
Posts: 6
Joined: Fri Jan 15, 2010 8:45 pm
Artica servers number: 1
Linux System: Ubuntu
Technical skills: A Geek

Re: demande d'aide de configuration

New postby admin » Mon Jan 18, 2010 11:52 am

Oui il manque les fichiers de config, vous les avez téléchargé sur la page web artica ?
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: demande d'aide de configuration

New postby Barman2010 » Mon Jan 18, 2010 1:14 pm

Autant pour moi! Désolé mais je débute et j'apprécie votre aide.

Je vais encore vous sollicitez pour ceci :

Code: Select all
Mon Jan 18 14:01:09 2010 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
Mon Jan 18 14:01:09 2010 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Mon Jan 18 14:01:09 2010 LZO compression initialized
Mon Jan 18 14:01:09 2010 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Mon Jan 18 14:01:09 2010 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Mon Jan 18 14:01:09 2010 Local Options hash (VER=V4): '41690919'
Mon Jan 18 14:01:09 2010 Expected Remote Options hash (VER=V4): '530fdded'
Mon Jan 18 14:01:09 2010 UDPv4 link local: [undef]
Mon Jan 18 14:01:09 2010 UDPv4 link remote: **.**.**.**:1194
Mon Jan 18 14:02:09 2010 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 18 14:02:09 2010 TLS Error: TLS handshake failed
Mon Jan 18 14:02:09 2010 TCP/UDP: Closing socket
Mon Jan 18 14:02:09 2010 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 18 14:02:09 2010 Restart pause, 2 second(s)


Je passe par un proxy indépendant pour aller sur le net, si je le précise dans la configuration openvpn je n'arrive pas du tout a avoir quelque chose. Est ce que mon proxy peu être la cause de mon erreur ?
Barman2010
 
Posts: 6
Joined: Fri Jan 15, 2010 8:45 pm
Artica servers number: 1
Linux System: Ubuntu
Technical skills: A Geek

Re: demande d'aide de configuration

New postby admin » Mon Jan 18, 2010 1:17 pm

tout à fait, la il essaye de se connecter en direct

Code: Select all
TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: demande d'aide de configuration

New postby Barman2010 » Mon Jan 18, 2010 1:18 pm

donc je dois lui préciser le proxy ?
Et si oui je le fais dans le fichier de configuration ?
Barman2010
 
Posts: 6
Joined: Fri Jan 15, 2010 8:45 pm
Artica servers number: 1
Linux System: Ubuntu
Technical skills: A Geek

Re: demande d'aide de configuration

New postby admin » Mon Jan 18, 2010 1:27 pm

pouvez-vous tester sans le proxy ?
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Re: demande d'aide de configuration

New postby Barman2010 » Mon Jan 18, 2010 1:35 pm

Avec l'option de l'interface openVPN GUI >> proxy setting >> use open vpn config-file setting

Code: Select all
Mon Jan 18 14:31:35 2010 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
Mon Jan 18 14:31:35 2010 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Mon Jan 18 14:31:35 2010 LZO compression initialized
Mon Jan 18 14:31:35 2010 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Mon Jan 18 14:31:35 2010 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Mon Jan 18 14:31:35 2010 Local Options hash (VER=V4): '41690919'
Mon Jan 18 14:31:35 2010 Expected Remote Options hash (VER=V4): '530fdded'
Mon Jan 18 14:31:35 2010 UDPv4 link local: [undef]
Mon Jan 18 14:31:35 2010 UDPv4 link remote: **.**.**.**:1194
Mon Jan 18 14:32:35 2010 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 18 14:32:35 2010 TLS Error: TLS handshake failed
Mon Jan 18 14:32:35 2010 TCP/UDP: Closing socket
Mon Jan 18 14:32:35 2010 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 18 14:32:35 2010 Restart pause, 2 second(s)


Avec l'option de l'interface openVPN GUI >> proxy setting >> HTTP proxy adress et port rempli

Code: Select all
Options error: --http-proxy MUST be used in TCP Client mode (i.e. --proto tcp-client)
Use --help for more information.
Barman2010
 
Posts: 6
Joined: Fri Jan 15, 2010 8:45 pm
Artica servers number: 1
Linux System: Ubuntu
Technical skills: A Geek

Re: demande d'aide de configuration

New postby admin » Mon Jan 18, 2010 1:43 pm

essayez cette solution :
http://www.exiledmind.net/vpn-tunnel
User avatar
admin
Site Admin
 
Posts: 11941
Joined: Wed Oct 17, 2007 7:59 am
Location: France

Next

Return to OpenVPN

Who is online

Users browsing this forum: No registered users and 1 guest

cron